docker-compose 버젼이 낮은상태에서 version: '2' 를 사용할 경우



1
ERROR: In file './docker-compose.yml' service 'version' doesn't have any configuration options. All top level keys in your docker-compose.yml must map to a dictionary of configuration options.
cs


위와 같은 에러가 발생한다.


그럴땐 docker-compose를 최신버젼으로 업데이트하자.


1
curl -L https://github.com/docker/compose/releases/download/1.6.2/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
cs



참고 : https://docs.docker.com/compose/install/

Posted by 사용자 guru_k

댓글을 달아 주세요